1.3より前のgemからupdteするとき

2回もググってしまったのでいい加減メモする

1.3より前のgemをupdateするとき

% sudo gem update --system

おかしいことになる.

% sudo gem install rubygems-update
% sudo update_rubygems

こうしなければならない.

1.3のgemなら冒頭の方法でもいいらしく、このやり方は1.3以前のバージョンから1.3以降のバージョンにアップデートするときだけの限定仕様なのだそう。

んで,以降は

% sudo gem update --system

でよい.


Author

ahomuAyumu Sato

overflow, Inc.VPoE

東京資本で生きる名古屋の鳥類

Web 技術、組織開発、料理、旅行、ランニングなど雑多なブログ

Bio: aho.mu
Twitter: @ahomu
Github: ahomu

Related

Latest

Archives

Tags

Search